NSLU2-Linux
view · edit · print · history

Your NSLU2 should meed the following requirements before you can install new packages via ipkg.

  1. Telnet access to your NSLU2. You probably already followed one of the two Howto's on the HowTo.HomePage.
  2. Upgraded firmware to Unslung. You probably followed the README link on the Unslung.HomePage.
  3. Full Internet access from the NSLU2 to the Internet. Ip routing and Dns resolution are required. Assuming you use a router/gateway you can change the required settings (DNS server, default gateway) on the normal NSLU2 admin web interface. If only your Windows PC has a dial up connection, you might need to consider ICS. Telnet into the NSLU2 and 'ping www.nslu2-linux.org' to confirm your Internet access.
  4. Updated list of available packages - you get that by running 'ipkg update'.

Keep in mind that sometimes the ipkg server doesn't respond correctly. If you get an error such as
wget: server returned error 404: HTTP/1.1 404 Not Found
ipkg_download: ERROR: Failed to retrieve http://ipkg.nslu2-linux.org/ipkg/...

then try again after a few seconds. If you are sure your internet connection is good, then don't give up. It has been seen that ipkg returned the 404 error 4 times in a row, and the 5th time it worked fine ...

view · edit · print · history · Last edited by kaste.
Based on work by kaste.
Originally by kai.
Page last modified on April 14, 2005, at 03:26 PM